<<Back to Land Rover Index

Land Rover Diary

Part Four: Speedos

First Posted: 21st Aug 2010 16:38

No, not the underwear... Really, some people!

As I have mentioned previously, I am currently having to guess my speed when driving my new Land Rover Defender 90, as the speedometer insists I'm doing 0 mph at all times. With practice, I can judge, from the roar of the engine, the scream of wind noise, and the glares of other road users just about how fast I'm going, but this is not ideal - nor is it legal.

So, after my success in fitting a bumper and side steps, with only minimal injury, and without breaking anything important, I resolved to get the speedo working.

So, new cable bought, I size up the job this morning over a cuppa.

My newly bought Haynes Manual is strangely reticent about speedometer cables - in fact on browsing the index, the only reference I can find is in a section on the instrument panel:

"disconnect the speedometer cable (where applicable) from the rear of the instrument panel, then carefully manoeuvre the instrument panel out of position"

Hmm... not a lot of help there, then. Look in the transfer box section, nothing... look in the gearbox section, nothing...

Right then, let's make it up as we go along!

Now, I know, from previous experience, that the speedo cable comes off the back of the transfer box, winds it's way round the gearbox and engine bay, and finally appears at the back of the aforementioned instrument panel.

Great, I've already read that bit.

So I follow the destructions and remove the instrument panel - as far as I am able, with a flippin' great steering wheel in the way. I did momentarily consider removing the steering wheel... then I regained my senses. Besides, I know I need the Landy tomorrow - I don't fancy steering with a pair of mole-grips.

It is actually perfectly possible to move the instrument panel forward enough to get your hand in and disconnect the speedo cable, so I did. I then drew the cable out of the dash far enough so I could see the end of it without craning my neck too much. Then, I drove down the lane, watching the end of the cable to see if it turned.

Have you ever noticed how suicidal sheep are?

I glanced up from the important job of watching the cable end, only to find a sheep standing watching me, IN THE MIDDLE OF THE LANE!

The brakes still work quite satisfactorily.

The speedo cable, however, doesn't.

Well we sort of knew that... but it saves putting a new one on, only to find it's the speedometer itself that is bust.


So, back at base, I open the bonnet and start to withdraw the cable from the back of the instrument panel through the bulkhead, trying not to destroy the whole wiring loom in the process.

I sometimes wish I had arms like that superhero - you know the one, he could stretch himself almost limitlessly - so I could have one hand under the bonnet drawing the cable out, and the other hand in the depths of the dashboard, feeding the end of the cable out.

That not being the case, however, I made do with running between the engine bay and cab, whilst pulling the cable half an inch at a time.

That end of the cable free, I left it dangling, and thought about the other end.

You can access the place where the cable exits the transfer box by removing the central front seat squab, and lifting the access panel from the top of the seat box.

Yees... the central seat squab... I looked under there when I was checking the Landy over two days ago...


That's the one where there is a rats nest of wiring, and a black box thingy that looks all ominous and easily broken.

So, taking a deep breath, I approach the cab, lean over the driver's seat and cautiously lift the central seat squab free. Nothing goes bang, or BOO!

Now being the proud owner of a Haynes manual, I've seen the pictures of the ECM, neatly attached to the base of the seat squab, with neatly harnessed wiring running down beneath the seat box.

Let me tell you, reality is a little different. The ECM is lying loose on the access panel, perched jauntily on what looks like an electricians junk heap of cables. I gingerly push things to one side, to find the attachment screws for the access plate and undo them.

I find there is enough slack on the wiring to lift the whole mess up and dump it unceremoniously on the passenger seat.

I remove the access panel and look down.

Can't see a thing! It's dark down there! Go and find a torch, turn it on, blind self by seeing if it was on, blink funny coloured shapes away from eyesight...


Right... well... I can see the cable, it disappears into a large lump of my old acquaintance, cow... er muck, that is stuffed into the gap between the end of the transfer box and the backplate of the transmission brake.

Get screwdriver, hack way at stuff until it grudgingly drops off to reveal the cable attachment point.

Blimey, it's tight - there must be all of an inch and a half gap to get my fingers into, what with the handbrake cable, the backplate of the handbrake and the end of the transfer box.

Still no problem... find quarter inch drive 10mm socket, extension bar and ratchet. gnnnnnnnnnnnhhhhhhhhhhhhh... WD40 time, I feel.


Don't you just hate it when the nut you are undoing is in such a position that you can't get a good swing on the ratchet wotsit... click... turn... click... turn... click...

Anyway, eventually it undoes enough to get a screwdriver handle onto the socket... then you realise the nut isn't turning, you are undoing the stud instead... Oh well, same thing really.

Stud comes free, funny shaped bracket disappears into undergrowth. Put stud and nut safely on floor of cab and release the end of the speedo cable.

Dive under Landy and retrieve funny shaped bracket after short search, and then pull rest of old speedo cable down past the clutch pedal doodah, the various things attached to the footwell, the main gearbox, the gearbox cross-member, the exhaust and the gearbox rear mountings. Hit head on various things in the process. Throw old cable out sideways from under Landy, and then get tangled up in it as I try to get out from underneath.

When I hold the two ends of the old cable together, and turn the gearbox feed end, nothing happens at the dashboard end - that's good then, proves it's busted.

Take new cable out of it's packaging, and repeat exercise - yep, both ends turn together.

Crawl back under Landy with new cable... nearly strangle myself whilst trying to straighten it out, but fit new gearbox end into hole in transfer box. Crawl back out from under Landy. Briefly hallucinate about how lovely it would be to have a gleaming workshop, with a hydraulic lift, and a polished concrete floor... trip over old speedo cable and measure my length on the gravel road - yep, still 5'7".


It is now, peering down from the where I lie on the driver's seat, that I realise the trap I have dug for myself.

If I had undone the nut from the stud, leaving the stud in situ on the transfer box casing, it would have been a simple matter to slide the bracket over the stud, and then I could have offered up the nut - inside the socket on the extension bar - and get it started on the stud.

As it is, I have to put the bracket over the cable, and then try and find, by touch, the location of the hole, and get the stud back in the hole it came from. Trouble is, there is no room for my hand to get into the right position to get the stud into the hole - I just can't do it, my hand won't fit between the backplate of the handbrake and the back of the transfer box whilst my fingers are gripping the stud at the right angle.


The Victorians had a terrible reputation for their use of child labour in the mines and factories. Thankfully this practice was stopped nearly two centuries ago.

My daughter is nine. She is a big fan of the Land Rover...

Well it was about time she got out of bed... eleven o'clock on a lovely sunny Saturday...

She was great. I explained the problem, and in no time she was head first in the hole between the front seats, with her legs waving in the air.

I dived back underneath to guide and encourage her, she only dropped the bracket on my face once, and we soon had that end fixed.

Then I routed the cable back through it's labyrinthine passage to the dash, and with my daughter's help fed it back through the bulkhead without ripping out any wires, and connected it to the speedometer.

We tidied up, and took a short jaunt down the lane... YES we have a working speedo!

I'd like to thank my daughter, without her this wouldn't have been possible.


Next time:

Lights, wires, stuff...



0 of 0 comments Show all

Please submit comments here:

 Please enter the validation code in the box below